PhpCodeFixer

Author(s)
Sergei Vanyushin
Website
https://github.com/wapmorgan/PhpCodeFixer
License
BSD 3-clause "New" or "Revised" License
GitHub
wapmorgan/PhpCodeFixer
Packagist
wapmorgan/php-code-fixer
DockerHub
phpqa/phpcf

0 0 0

PhpCodeFixer finds deprecated functions, wrong functions usage, variables, ini directives and restricted identifiers in your php code.

It literally helps you fix code that can fail after migration to PHP 7.

Installation

Install from a Composer package as a dev dependency (with Composer)

Make sure you have Composer installed.

Require it as a dev dependency:
composer require --dev wapmorgan/php-code-fixer
Run it:
php vendor/bin/phpcf

Install from a Composer package as a global CLI utility (with Composer)

Make sure you have Composer installed.

Require it as a global CLI utility:
composer global require wapmorgan/php-code-fixer
Run it:
phpcf
Make sure your global vendor binaries directory is in your $PATH environment variable. Check the Composer documentation for more information.